cve.bz

CVE-2020-7748

8.1 highEPSS 1.7%

High (8.1) in ts.ed project ts.ed. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in @tsed/core 5.65.7.

This affects the package @tsed/core before 5.65.7. This vulnerability relates to the deepExtend function which is used as part of the utils directory. Depending on if user input is provided, an attacker can overwrite and pollute the object prototype of a program.

Severity

CVSS 3.1

8.1 high
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.7% chance of exploitation in the next 30 days; higher than 77% of CVEs (scores of 2026-10-31)
CWE
CWE-1321
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-77xq-cpvg-7xm2npm@tsed/core<5.65.75.65.7

References

Check your stackJSON