cve.bz

CVE-2020-26892

9.8 criticalEPSS 2.3%

Critical (9.8). EPSS 2.3% chance of exploitation in the next 30 days. Fixed in github.com/nats-io/nats-server/v2 2.1.9.

The JWT library in NATS nats-server before 2.1.9 has Incorrect Access Control because of how expired credentials are handled.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.3% chance of exploitation in the next 30 days; higher than 83% of CVEs (scores of 2026-10-31)
CWE
CWE-798
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-2c64-vj8g-vwrqGogithub.com/nats-io/nats-server/v2<2.1.92.1.9
GHSA-4w5x-x539-ppf5Gogithub.com/nats-io/jwt<1.1.01.1.0
GO-2022-0380Gogithub.com/nats-io/jwt<1.1.01.1.0

References

Check your stackJSON