CVE-2020-26217
XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
- CVSS 3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- 83% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-25)
- CWE
- CWE-78
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:activemq
- debian:debian_linux
- netapp:snapmanager
- oracle:banking_cash_management
- oracle:banking_corporate_lending_process_management
- oracle:banking_credit_facilities_process_management
- oracle:banking_platform
- oracle:banking_supply_chain_finance
- oracle:banking_trade_finance_process_management
- oracle:banking_virtual_account_management
- oracle:business_activity_monitoring
- oracle:communications_policy_management
- oracle:endeca_information_discovery_studio
- oracle:retail_xstore_point_of_service
- xstream:xstream
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-mw36-7c6c-q4q2 | Maven | com.thoughtworks.xstream:xstream | <1.4.14-java7 | 1.4.14-java7 |
References
- https://github.com/x-stream/xstream/commit/0fec095d534126931c99fd38e9c6d41f5c685c1a
- https://github.com/x-stream/xstream/security/advisories/GHSA-mw36-7c6c-q4q2
- https://lists.apache.org/thread.html/r2de526726e7f4db4a7cb91b7355070779f51a84fd985c6529c2f4e9e%40%3Cissues.activemq.apache.org%3E
- https://lists.apache.org/thread.html/r7c9fc255edc0b9cd9567093d131f6d33fde4c662aaf912460ef630e9%40%3Ccommits.camel.apache.org%3E
- https://lists.apache.org/thread.html/r826a006fda71cc96fc87b6eca4b5d195f19a292ad36cea501682c38c%40%3Cissues.activemq.apache.org%3E