cve.bz

CVE-2020-2206

6.1 mediumEPSS 0.9%

Medium (6.1) in jenkins vncrecorder. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.plugins:vncrecorder 1.35.

Jenkins VncRecorder Plugin 1.25 and earlier does not escape a parameter value in the checkVncServ form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.9% chance of exploitation in the next 30 days; higher than 58% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fq52-6cjf-jw59Mavenorg.jenkins-ci.plugins:vncrecorder<1.351.35

References

Check your stackJSON