Medium (4.8) in jenkins vncrecorder. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.plugins:vncrecorder 1.35.
Jenkins VncRecorder Plugin 1.25 and earlier does not escape a tool path in the `checkVncServ` form validation endpoint, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by Jenkins administrators.
Severity
CVSS 3.1
4.8 medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
0.7% chance of exploitation in the next 30 days; higher than 53% of CVEs (scores of 2026-10-31)