CVE-2020-17521
Apache Groovy provides extension methods to aid with creating temporary directories. Prior to this fix, Groovy's implementation of those extension methods was using a now superseded Java JDK method call that is potentially not secure on some operating systems in some contexts. Users not using the extension methods mentioned in the advisory are not affected, but may wish to read the advisory for further details. Versions Affected: 2.0 to 2.4.20, 2.5.0 to 2.5.13, 3.0.0 to 3.0.6, and 4.0.0-alpha-1. Fixed in versions 2.4.21, 2.5.14, 3.0.7, 4.0.0-alpha-2.
- CVSS 3.1
- 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - EPSS
- 1.0% chance of exploitation in the next 30 days; higher than 63% of CVEs (scores of 2026-10-25)
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:atlas
- apache:groovy
- netapp:snapcenter
- oracle:agile_engineering_data_management
- oracle:agile_plm_mcad_connector
- oracle:agile_product_lifecycle_management
- oracle:business_process_management_suite
- oracle:communications_brm_-_elastic_charging_engine
- oracle:communications_diameter_signaling_router
- oracle:communications_evolved_communications_application_server
- oracle:communications_services_gatekeeper
- oracle:healthcare_data_repository
- oracle:hospitality_opera_5
- oracle:ilearning
- oracle:insurance_policy_administration
- oracle:jd_edwards_enterpriseone_orchestrator
- oracle:primavera_gateway
- oracle:primavera_unifier
- oracle:retail_bulk_data_integration
- oracle:retail_merchandising_system
- oracle:retail_store_inventory_management
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-rcjj-h6gh-jf3r | Maven | org.codehaus.groovy:groovy | >=2.0.0 <2.4.21 | 2.4.21 |
| GHSA-rcjj-h6gh-jf3r | Maven | org.codehaus.groovy:groovy | >=2.5.0 <2.5.14 | 2.5.14 |
| GHSA-rcjj-h6gh-jf3r | Maven | org.codehaus.groovy:groovy | >=3.0.0 <3.0.7 | 3.0.7 |
| GHSA-rcjj-h6gh-jf3r | Maven | org.codehaus.groovy:groovy-all | >=2.0.0 <2.4.21 | 2.4.21 |
| GHSA-rcjj-h6gh-jf3r | Maven | org.codehaus.groovy:groovy-all | >=2.5.0 <2.5.14 | 2.5.14 |
| GHSA-rcjj-h6gh-jf3r | Maven | org.codehaus.groovy:groovy-all | >=3.0.0 <3.0.7 | 3.0.7 |
References
- https://groovy-lang.org/security.html#CVE-2020-17521
- https://lists.apache.org/thread.html/r4b2f13c302eec98838ff7475253091fb9b75bc1038016ba00ebf6c08%40%3Cdev.atlas.apache.org%3E
- https://lists.apache.org/thread.html/ra9dab34bf8625511f23692ad0fcee2725f782e9aad6c5cdff6cf4465%40%3Cnotifications.groovy.apache.org%3E
- https://lists.apache.org/thread.html/rea63a4666ba245d2892471307772a2d8ce0f0741f341d6576625c1b3%40%3Cdev.atlas.apache.org%3E
- https://security.netapp.com/advisory/ntap-20201218-0006/