cve.bz

CVE-2020-1747

9.8 criticalEPSS 5.4%

Critical (9.8). EPSS 5.4% chance of exploitation in the next 30 days. Fixed in pyyaml 5.3.1.

A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. An attacker could use this flaw to execute arbitrary code on the system by abusing the python/object/new constructor.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
5.4% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6757-jp84-gxfxPyPIpyyaml>=5.1b7 <5.3.15.3.1
PYSEC-2020-96PyPIpyyaml>=5.1 <5.3.15.3.1

References

Check your stackJSON