cve.bz

CVE-2020-1739

3.9 lowEPSS 0.4%

Low (3.9). EPSS 0.4% chance of exploitation in the next 30 days. Fixed in ansible 2.7.17, 2.8.11, 2.8.9.

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

Severity

CVSS 3.1

3.9 low
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 29% of CVEs (scores of 2026-10-31)
CWE
CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-923p-fr2c-g5m2PyPIansible<2.7.172.7.17
GHSA-923p-fr2c-g5m2PyPIansible>=2.8.0a1 <2.8.112.8.11
GHSA-923p-fr2c-g5m2PyPIansible>=2.9.0a1 <2.9.72.9.7
PYSEC-2020-11PyPIansible<2.7.17
>=2.8.0 <2.8.9
>=2.9.0 <2.9.6
2.7.17, 2.8.9, 2.9.6

References

Check your stackJSON