cve.bz

CVE-2020-1738

3.9 lowEPSS 0.4%

Low (3.9) in redhat. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in ansible 2.7.17, 2.8.9, 2.9.6.

A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task is executed with a malicious user, the module sent can be selected by the attacker using the ansible facts file. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

Severity

CVSS 3.1

3.9 low
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L
EPSS
0.4% chance of exploitation in the next 30 days; higher than 34% of CVEs (scores of 2026-10-31)
CWE
CWE-88
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f85h-23mf-2fwhPyPIansible<=2.7.16no fix published
GHSA-f85h-23mf-2fwhPyPIansible>=2.8.0a1 <=2.8.10no fix published
GHSA-f85h-23mf-2fwhPyPIansible>=2.9.0a1 <=2.9.6no fix published
PYSEC-2020-10PyPIansible<2.7.17
>=2.8.0 <2.8.9
>=2.9.0 <2.9.6
2.7.17, 2.8.9, 2.9.6

References

Check your stackJSON