cve.bz

CVE-2020-1735

4.6 mediumEPSS 0.5%

Medium (4.6). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in ansible 2.7.17, 2.7.18, 2.8.12.

A flaw was found in the Ansible Engine when the fetch module is used. An attacker could intercept the module, inject a new path, and then choose a new destination path on the controller node. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

Severity

CVSS 3.1

4.6 medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-22
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-gfr2-qpxh-qj9mPyPIansible>=2.7.0a1 <2.7.182.7.18
GHSA-gfr2-qpxh-qj9mPyPIansible>=2.8.0a1 <2.8.122.8.12
GHSA-gfr2-qpxh-qj9mPyPIansible>=2.9.0a1 <2.9.82.9.8
PYSEC-2020-7PyPIansible<2.7.17
>=2.8.0 <2.8.9
>=2.9.0 <2.9.6
2.7.17, 2.8.9, 2.9.6

References

Check your stackJSON