cve.bz

CVE-2020-1734

7.4 highEPSS 0.5%

High (7.4) in redhat. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in ansible 2.10.0rc1, 2.7.17, 2.8.13.

A flaw was found in the pipe lookup plugin of ansible. Arbitrary commands can be run, when the pipe lookup plugin uses subprocess.Popen() with shell=True, by overwriting ansible facts and the variable is not escaped by quote plugin. An attacker could take advantage and run arbitrary commands by overwriting the ansible facts.

Severity

CVSS 3.1

7.4 high
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L
EPSS
0.5% chance of exploitation in the next 30 days; higher than 39% of CVEs (scores of 2026-10-31)
CWE
CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h39q-95q5-9jfpPyPIansible>=2.10.0a1 <2.10.0rc12.10.0rc1
GHSA-h39q-95q5-9jfpPyPIansible>=2.9.0a1 <2.9.112.9.11
GHSA-h39q-95q5-9jfpPyPIansible<2.8.132.8.13
PYSEC-2020-6PyPIansible<2.7.172.7.17

References

Check your stackJSON