cve.bz

CVE-2020-15240

9.1 criticalEPSS 0.8%

Critical (9.1) in auth0 omniauth-auth0. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in omniauth-auth0 2.4.1.

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
0.8% chance of exploitation in the next 30 days; higher than 56% of CVEs (scores of 2026-10-31)
CWEs
CWE-347, CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-58r4-h6v8-jcvmRubyGemsomniauth-auth0>=2.3.0 <2.4.12.4.1

References

Check your stackJSON