cve.bz

CVE-2020-15125

7.7 highEPSS 1.5%

High (7.7) in auth0 auth0.js. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in auth0 2.27.1.

In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be sanitized from the request object contained in the error object is used. The key for Authorization header is not sanitized and in certain cases the Authorization header value can be logged exposing a bearer token. You are affected by this vulnerability if you are using the auth0 npm package, and you are using a Machine to Machine application authorized to use Auth0's management API

Severity

CVSS 3.1

7.7 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
1.5% chance of exploitation in the next 30 days; higher than 74% of CVEs (scores of 2026-11-01)
CWE
CWE-209
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5jpf-pj32-xx53npmauth0<2.27.12.27.1

References

Check your stackJSON