cve.bz

CVE-2020-15119

5.4 mediumEPSS 0.5%

Medium (5.4) in auth0 lock. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in auth0-lock 11.26.3.

In auth0-lock versions before and including 11.25.1, dangerouslySetInnerHTML is used to update the DOM. When dangerouslySetInnerHTML is used, the application and its users might be exposed to cross-site scripting (XSS) attacks.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6gg3-pmm7-97xcnpmauth0-lock<11.26.311.26.3

References

Check your stackJSON