cve.bz

CVE-2020-15107

5.3 mediumEPSS 0.3%

Medium (5.3) in openenclave openenclave. EPSS 0.3% chance of exploitation in the next 30 days.

In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.

Severity

CVSS 3.1

5.3 medium
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:N
EPSS
0.3% chance of exploitation in the next 30 days; higher than 26% of CVEs (scores of 2026-10-31)
Published
Modified
Record from
the NVD, synced

Affected

References

Check your stackJSON