Critical (9.8) in python jw.util. EPSS 4.5% chance of exploitation in the next 30 days. Fixed in jw-util 2.3.
An exploitable vulnerability exists in the configuration-loading functionality of the jw.util package before 2.3 for Python. When loading a configuration with FromString or FromStream with YAML, one can execute arbitrary Python code, resulting in OS command execution, because safe_load is not used.
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
4.5% chance of exploitation in the next 30 days; higher than 91% of CVEs (scores of 2026-10-31)