cve.bz

CVE-2020-11020

9.8 criticalEPSS 1.6%

Critical (9.8) in faye project faye. EPSS 1.6% chance of exploitation in the next 30 days. Fixed in faye 1.0.4, 1.1.3, 1.2.5.

Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.6% chance of exploitation in the next 30 days; higher than 75% of CVEs (scores of 2026-10-31)
CWE
CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qpg4-4w7w-2mq5RubyGemsfaye>=0.5.0 <1.0.41.0.4
GHSA-qpg4-4w7w-2mq5RubyGemsfaye>=1.1.0 <1.1.31.1.3
GHSA-qpg4-4w7w-2mq5RubyGemsfaye>=1.2.0 <1.2.51.2.5

References

Check your stackJSON