cve.bz

CVE-2020-11002

8.8 highEPSS 5.2%

High (8.8) in dropwizard dropwizard validation. EPSS 5.2% chance of exploitation in the next 30 days. Fixed in io.dropwizard:dropwizard-validation 1.3.21, 2.0.3.

dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
5.2% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWE
CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8jpx-m2wh-2v34Mavenio.dropwizard:dropwizard-validation<1.3.211.3.21
GHSA-8jpx-m2wh-2v34Mavenio.dropwizard:dropwizard-validation>=2.0.0 <2.0.32.0.3

References

Check your stackJSON