cve.bz

CVE-2020-11001

6.8 mediumEPSS 1.3%

Medium (6.8) in torchbox wagtail. EPSS 1.3% chance of exploitation in the next 30 days. Fixed in wagtail 2.7.2, 2.8.1.

In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).

Severity

CVSS 3.1

6.8 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
EPSS
1.3% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)
CWEs
CWE-79, CWE-80
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v2wc-pfq2-5cm6PyPIwagtail>=1.9.0 <2.7.22.7.2
GHSA-v2wc-pfq2-5cm6PyPIwagtail>=2.8.0 <2.8.12.8.1
PYSEC-2020-152PyPIwagtail>=1.9 <2.7.22.7.2

References

Check your stackJSON