cve.bz

CVE-2020-10755

6.5 mediumEPSS 1.2%

Medium (6.5). EPSS 1.2% chance of exploitation in the next 30 days. Fixed in cinder 14.1.0, 15.2.0, 16.1.0.

An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)
CWE
CWE-522
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v3m2-pg96-w33mPyPIcinder>=14.0.0 <14.1.014.1.0
GHSA-v3m2-pg96-w33mPyPIcinder>=15.0.0 <15.2.015.2.0
GHSA-v3m2-pg96-w33mPyPIcinder>=16.0.0 <16.1.016.1.0
GHSA-v3m2-pg96-w33mPyPIos-brick>=2.8.0 <2.8.62.8.6
GHSA-v3m2-pg96-w33mPyPIos-brick>=2.10.0 <2.10.42.10.4
GHSA-v3m2-pg96-w33mPyPIos-brick>=3.0.0 <3.0.23.0.2
PYSEC-2020-228PyPIcinder<14.1.0
>=15.0.0 <15.2.0
>=16.0.0 <16.1.0
14.1.0, 15.2.0, 16.1.0
PYSEC-2026-891PyPIos-brick>=2.8.0 <2.8.6
>=2.10.0 <2.10.4
>=3.0.0 <3.0.2
2.8.6, 2.10.4, 3.0.2

References

Check your stackJSON