cve.bz

CVE-2019-8324

8.8 highEPSS 3.2%

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
3.2% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-76wm-422q-92mqRubyGemsrubygems-update>=2.6.0 <2.7.92.7.9
GHSA-76wm-422q-92mqRubyGemsrubygems-update>=3.0.0 <3.0.23.0.2

References

Check your stackJSON