cve.bz

CVE-2019-8321

7.5 highEPSS 3.3%

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
3.3% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
CWE
CWE-88
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fr32-gr5c-xq5cRubyGemsrubygems-update>=2.6.0 <2.7.92.7.9
GHSA-fr32-gr5c-xq5cRubyGemsrubygems-update>=3.0.0 <3.0.23.0.2

References

Check your stackJSON