cve.bz

CVE-2019-20477

9.8 criticalEPSS 5.1%

Critical (9.8). EPSS 5.1% chance of exploitation in the next 30 days. Fixed in pyyaml 5.2, 5.2b1.

PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
5.1% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3pqx-4fqf-j49fPyPIpyyaml>=5.1 <5.25.2
PYSEC-2020-176PyPIpyyaml>=5.1 <5.2b15.2b1

References

Check your stackJSON