cve.bz

CVE-2019-17383

9.8 criticalEPSS 2.4%

Critical (9.8) in netaddr project netaddr. EPSS 2.4% chance of exploitation in the next 30 days. Fixed in netaddr 1.5.3, 2.0.4.

The netaddr gem before 2.0.4 for Ruby has misconfigured file permissions, such that a gem install may result in 0777 permissions in the target filesystem.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.4% chance of exploitation in the next 30 days; higher than 83% of CVEs (scores of 2026-10-31)
CWE
CWE-276
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-49pj-69vf-c689RubyGemsnetaddr>=2.0.0 <2.0.42.0.4
GHSA-49pj-69vf-c689RubyGemsnetaddr<1.5.31.5.3

References

Check your stackJSON