cve.bz

CVE-2019-12303

8.8 highEPSS 2.0%

High (8.8) in suse rancher. EPSS 2.0% chance of exploitation in the next 30 days. Fixed in github.com/rancher/rancher 2.2.4, 2.2.4+incompatible.

In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to read files or execute arbitrary commands inside the fluentd container.

Severity

CVSS 3.0

8.8 high
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
2.0% chance of exploitation in the next 30 days; higher than 80% of CVEs (scores of 2026-10-31)
CWE
CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-53pj-67m4-9w98Gogithub.com/rancher/rancher>=2.0.0 <2.2.42.2.4
GO-2024-2762Gogithub.com/rancher/rancher>=2.0.0+incompatible <2.2.4+incompatible2.2.4+incompatible

References

Check your stackJSON