cve.bz

CVE-2019-11253

7.5 highEPSS 26%

Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
26% chance of exploitation in the next 30 days; higher than 97% of CVEs (scores of 2026-10-31)
CWEs
CWE-776, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pmqp-h87c-mr78Gok8s.io/kubernetes>=1.0.0 <1.13.121.13.12
GHSA-pmqp-h87c-mr78Gok8s.io/kubernetes>=1.14.0 <1.14.81.14.8
GHSA-pmqp-h87c-mr78Gok8s.io/kubernetes>=1.15.0 <1.15.51.15.5
GHSA-pmqp-h87c-mr78Gok8s.io/kubernetes>=1.16.0 <1.16.21.16.2
GO-2022-0703Gok8s.io/kubernetes>=1.0.0 <1.13.12
>=1.14.0 <1.14.8
>=1.15.0 <1.15.5
>=1.16.0 <1.16.2
1.13.12, 1.14.8, 1.15.5, 1.16.2

References

Check your stackJSON