cve.bz

CVE-2019-1002100

6.5 mediumEPSS 17%

Medium (6.5). EPSS 17% chance of exploitation in the next 30 days. Fixed in k8s.io/kubernetes 1.11.8, 1.12.6, 1.13.4.

In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. `kubectl patch --type json` or `"Content-Type: application/json-patch+json"`) that consumes excessive resources while processing, causing a Denial of Service on the API Server.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
17% chance of exploitation in the next 30 days; higher than 97% of CVEs (scores of 2026-10-31)
CWE
CWE-770
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-q4rr-64r9-fwgfGok8s.io/kubernetes>=1.0.0 <=1.10.14no fix published
GHSA-q4rr-64r9-fwgfGok8s.io/kubernetes>=1.11.0 <1.11.81.11.8
GHSA-q4rr-64r9-fwgfGok8s.io/kubernetes>=1.12.0 <1.12.61.12.6
GHSA-q4rr-64r9-fwgfGok8s.io/kubernetes>=1.13.0 <1.13.41.13.4
GO-2023-1946Gok8s.io/kubernetes>=1.0.0 <1.11.8
>=1.12.0 <1.12.6
>=1.13.0 <1.13.4
1.11.8, 1.12.6, 1.13.4

References

Check your stackJSON