cve.bz

CVE-2019-0542

8.8 highEPSS 3.2%

High (8.8). EPSS 3.2% chance of exploitation in the next 30 days. Fixed in xterm 3.10.1, 3.8.1, 3.9.2.

A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
3.2% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mc23-976p-j42xnpmxterm<3.8.13.8.1
GHSA-mc23-976p-j42xnpmxterm>=3.9.0 <3.9.23.9.2
GHSA-mc23-976p-j42xnpmxterm>=3.10.0 <3.10.13.10.1

References

Check your stackJSON