cve.bz

CVE-2018-16476

7.5 highEPSS 2.9%

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

Severity

CVSS 3.0

7.5 high
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
2.9% chance of exploitation in the next 30 days; higher than 86% of CVEs (scores of 2026-10-31)
CWEs
CWE-502, CWE-284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-q2qw-rmrh-vv42RubyGemsactivejob>=4.2.0 <4.2.114.2.11
GHSA-q2qw-rmrh-vv42RubyGemsactivejob>=5.0.0 <5.0.7.15.0.7.1
GHSA-q2qw-rmrh-vv42RubyGemsactivejob>=5.1.0 <5.1.6.15.1.6.1
GHSA-q2qw-rmrh-vv42RubyGemsactivejob>=5.2.0 <5.2.1.15.2.1.1

References

Check your stackJSON