cve.bz

CVE-2018-12545

7.5 highEPSS 5.1%

High (7.5). EPSS 5.1% chance of exploitation in the next 30 days. Fixed in org.eclipse.jetty:jetty-server 9.3.25.v20180904, 9.4.12.v20180830.

In Eclipse Jetty version 9.3.x and 9.4.x, the server is vulnerable to Denial of Service conditions if a remote client sends either large SETTINGs frames container containing many settings, or many small SETTINGs frames. The vulnerability is due to the additional CPU and memory allocations required to handle changed settings.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
5.1% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWEs
CWE-770, CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h2f4-v4c4-6wx4Mavenorg.eclipse.jetty:jetty-server>=9.4.0 <9.4.12.v201808309.4.12.v20180830
GHSA-h2f4-v4c4-6wx4Mavenorg.eclipse.jetty:jetty-server>=9.3.0 <9.3.25.v201809049.3.25.v20180904

References

Check your stackJSON