cve.bz

CVE-2018-11777

8.1 highEPSS 2.3%

High (8.1) in apache hive. EPSS 2.3% chance of exploitation in the next 30 days. Fixed in org.apache.hive:hive-exec 2.3.4, 3.1.1.

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Severity

CVSS 3.0

8.1 high
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
2.3% chance of exploitation in the next 30 days; higher than 83% of CVEs (scores of 2026-10-31)
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rrfq-g5fq-fc9cMavenorg.apache.hive:hive-exec>=3.0.0 <3.1.13.1.1
GHSA-rrfq-g5fq-fc9cMavenorg.apache.hive:hive-exec<2.3.42.3.4

References

Check your stackJSON