cve.bz

CVE-2018-10875

7.8 highEPSS 0.6%

High (7.8). EPSS 0.6% chance of exploitation in the next 30 days. Fixed in ansible 2.4.6.0, 2.5.6, 2.6.1.

A flaw was found in ansible. ansible.cfg is read from the current working directory which can be altered to make it point to a plugin or a module path under the control of an attacker, thus allowing the attacker to execute arbitrary code.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 48% of CVEs (scores of 2026-10-31)
CWE
CWE-426
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fc4h-467w-46rhPyPIansible<2.4.6.02.4.6.0
GHSA-fc4h-467w-46rhPyPIansible>=2.5.0a1 <2.5.62.5.6
GHSA-fc4h-467w-46rhPyPIansible>=2.6.0a1 <2.6.12.6.1
PYSEC-2018-43PyPIansible>=2.5 <2.5.6
>=2.4 <2.4.6.0
>=2.6 <2.6.1
2.5.6, 2.4.6.0, 2.6.1

References

Check your stackJSON