cve.bz

CVE-2018-1002105

9.8 criticalEPSS 87%

Critical (9.8). EPSS 87% chance of exploitation in the next 30 days. Fixed in github.com/kubernetes/kubernetes 1.10.11, 1.11.5, 1.12.3.

In all Kubernetes versions prior to v1.10.11, v1.11.5, and v1.12.3, incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.

Severity

CVSS 3.0

9.8 critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
87% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWE
CWE-388
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-579h-mv94-g4gpGogithub.com/kubernetes/kubernetes<1.10.111.10.11
GHSA-579h-mv94-g4gpGogithub.com/kubernetes/kubernetes>=1.11.0 <1.11.51.11.5
GHSA-579h-mv94-g4gpGogithub.com/kubernetes/kubernetes>=1.12.0 <1.12.31.12.3
GO-2022-0792Gogithub.com/kubernetes/kubernetes<1.10.11
>=1.11.0 <1.11.5
>=1.12.0 <1.12.3
1.10.11, 1.11.5, 1.12.3

References

Check your stackJSON