High (7.8) in sonarsource sonarqube scanner. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.plugins:sonar 2.8.1.
An insufficiently protected credentials vulnerability exists in Jenkins SonarQube Scanner Plugin 2.8 and earlier in SonarInstallation.java that allows attackers with local file system access to obtain the credentials used to connect to SonarQube.
Severity
CVSS 3.0
7.8 high
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 27% of CVEs (scores of 2026-10-31)