cve.bz

CVE-2017-7474

9.8 criticalEPSS 2.5%

Critical (9.8) in keycloak keycloak-nodejs-auth-utils. EPSS 2.5% chance of exploitation in the next 30 days. Fixed in keycloak-connect 3.1.0.

It was found that the Keycloak Node.js adapter 2.5 - 3.0 did not handle invalid tokens correctly. An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.

Severity

CVSS 3.0

9.8 critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.5% chance of exploitation in the next 30 days; higher than 84% of CVEs (scores of 2026-10-31)
CWE
CWE-253
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mw35-24gh-f82wnpmkeycloak-connect>=2.5.0 <3.1.03.1.0
GHSA-mw35-24gh-f82wnpmkeycloak-js>=2.5.0 <3.1.03.1.0

References

Check your stackJSON