cve.bz

CVE-2017-7466

8.0 highEPSS 3.0%

High (8.0) in redhat. EPSS 3.0% chance of exploitation in the next 30 days. Fixed in ansible 2.2.3.0, 2.3.0.0.

Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Severity

CVSS 3.0

8.0 high
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
3.0% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3m8p-xpm6-8ww3PyPIansible<2.2.3.02.2.3.0
PYSEC-2018-40PyPIansible<2.3.0.02.3.0.0

References

Check your stackJSON