cve.bz

CVE-2017-2809

7.8 highEPSS 3.0%

High (7.8) in ansible-vault project ansible-vault. EPSS 3.0% chance of exploitation in the next 30 days. Fixed in ansible-vault 1.0.5.

An exploitable vulnerability exists in the yaml loading functionality of ansible-vault before 1.0.5. A specially crafted vault can execute arbitrary python commands resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.

Severity

CVSS 3.0

7.8 high
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
3.0% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-c2w9-48qc-qpj4PyPIansible-vault<1.0.51.0.5
PYSEC-2017-5PyPIansible-vault<1.0.51.0.5

References

Check your stackJSON