cve.bz

CVE-2017-18342

9.8 criticalEPSS 5.7%

Critical (9.8). EPSS 5.7% chance of exploitation in the next 30 days. Fixed in pyyaml 5.1.

In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
5.7% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rprw-h62v-c2w7PyPIpyyaml<5.15.1
PYSEC-2018-49PyPIpyyaml<5.15.1

References

Check your stackJSON