cve.bz

CVE-2017-17458

9.8 criticalEPSS 6.3%

Critical (9.8). EPSS 6.3% chance of exploitation in the next 30 days. Fixed in mercurial 4.4.1.

In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.

Severity

CVSS 3.0

9.8 critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
6.3% chance of exploitation in the next 30 days; higher than 93% of CVEs (scores of 2026-10-31)
CWE
CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-6v56-cpg6-3rpxPyPImercurial<4.4.14.4.1
PYSEC-2017-90PyPImercurial<4.4.14.4.1

References

Check your stackJSON