cve.bz

CVE-2017-10784

8.8 highEPSS 16%

High (8.8) in ruby-lang ruby. EPSS 16% chance of exploitation in the next 30 days. Fixed in webrick 1.4.0.

The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.

Severity

CVSS 3.0

8.8 high
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
16% chance of exploitation in the next 30 days; higher than 96% of CVEs (scores of 2026-10-31)
CWE
CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-369m-2gv6-mw28RubyGemswebrick<1.4.01.4.0

References

Check your stackJSON