cve.bz

CVE-2017-10689

5.5 mediumEPSS 0.4%

Medium (5.5). EPSS 0.4% chance of exploitation in the next 30 days. Fixed in puppet 4.10.10, 5.3.4.

In previous versions of Puppet Agent it was possible to install a module with world writable permissions. Puppet Agent 5.3.4 and 1.10.10 included a fix to this vulnerability.

Severity

CVSS 3.0

5.5 medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 29% of CVEs (scores of 2026-10-31)
CWE
CWE-269
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vw22-465p-8j5wRubyGemspuppet<4.10.104.10.10
GHSA-vw22-465p-8j5wRubyGemspuppet>=5.0.0 <5.3.45.3.4

References

Check your stackJSON