cve.bz

CVE-2017-0902

8.1 highEPSS 4.8%

RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

Severity

CVSS 3.0

8.1 high
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
4.8% chance of exploitation in the next 30 days; higher than 91% of CVEs (scores of 2026-10-31)
CWEs
CWE-346, CWE-350
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-73w7-6w9g-gc8wRubyGemsrubygems-update<2.6.132.6.13

References

Check your stackJSON