cve.bz

CVE-2016-9015

3.7 lowEPSS 0.8%

Low (3.7) in python urllib3. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in urllib3 1.18.1.

Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the library with those configurations at risk of man-in-the-middle and information leakage attacks. This vulnerability affects users using versions 1.17 and 1.18 of the urllib3 library, who are using the optional PyOpenSSL support for TLS instead of the regular standard library TLS backend, and who are using OpenSSL 1.1.0 via PyOpenSSL. This is an extremely uncommon configuration, so the security impact of this vulnerability is low.

Severity

CVSS 3.0

3.7 low
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
0.8% chance of exploitation in the next 30 days; higher than 55% of CVEs (scores of 2026-10-31)
CWE
CWE-295
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v4w5-p2hg-8fh6PyPIurllib3>=1.17 <1.18.11.18.1
PYSEC-2017-98PyPIurllib3>=1.17 <1.18.11.18.1

References

Check your stackJSON