cve.bz

CVE-2016-6316

6.1 mediumEPSS 3.4%

Medium (6.1). EPSS 3.4% chance of exploitation in the next 30 days. Fixed in actionview 3.2.22.3, 4.2.7.1, 5.0.0.1.

Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 might allow remote attackers to inject arbitrary web script or HTML via text declared as "HTML safe" and used as attribute values in tag handlers.

Severity

CVSS 3.0

6.1 medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
3.4% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pc3m-v286-2jwjRubyGemsactionview>=3.0.0 <3.2.22.33.2.22.3
GHSA-pc3m-v286-2jwjRubyGemsactionview>=4.0.0 <4.2.7.14.2.7.1
GHSA-pc3m-v286-2jwjRubyGemsactionview>=5.0.0 <5.0.0.15.0.0.1

References

Check your stackJSON