cve.bz

CVE-2016-3956

7.5 highEPSS 5.5%

High (7.5). EPSS 5.5% chance of exploitation in the next 30 days. Fixed in npm 2.15.1, 3.8.3.

The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0, includes bearer tokens with arbitrary requests, which allows remote HTTP servers to obtain sensitive information by reading Authorization headers.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
5.5% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWE
CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-m5h6-hr3q-22h5npmnpm<2.15.12.15.1
GHSA-m5h6-hr3q-22h5npmnpm>=3.0.0 <3.8.33.8.3

References

Check your stackJSON