cve.bz

CVE-2015-9251

6.1 mediumEPSS 30%

Medium (6.1). EPSS 30% chance of exploitation in the next 30 days. Fixed in jquery 1.12.2, 3.0.0.

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

Severity

CVSS 3.0

6.1 medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
30% chance of exploitation in the next 30 days; higher than 98% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rmxg-73gg-4p98npmjquery<1.12.21.12.2
GHSA-rmxg-73gg-4p98NuGetjQuery<1.12.21.12.2
GHSA-rmxg-73gg-4p98NuGetjQuery>=1.12.3 <3.0.03.0.0
GHSA-rmxg-73gg-4p98npmjquery>=1.12.3 <3.0.03.0.0
GHSA-rmxg-73gg-4p98RubyGemsjquery-rails<4.2.04.2.0
GHSA-rmxg-73gg-4p98Mavenorg.webjars.npm:jquery<1.12.21.12.2
GHSA-rmxg-73gg-4p98Mavenorg.webjars.npm:jquery>=1.12.3 <3.0.03.0.0

References

Check your stackJSON