cve.bz

CVE-2015-8857

9.8 criticalEPSS 3.6%

Critical (9.8) in uglifyjs project uglifyjs. EPSS 3.6% chance of exploitation in the next 30 days. Fixed in uglify-js 2.4.24.

The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.6% chance of exploitation in the next 30 days; higher than 89% of CVEs (scores of 2026-10-31)
CWE
CWE-254
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-34r7-q49f-h37cnpmuglify-js<2.4.242.4.24
GHSA-34r7-q49f-h37cRubyGemsuglifier<2.7.22.7.2

References

Check your stackJSON