CVE-2015-2241
djangoproject django: no CVSS score yet. EPSS 2.1% chance of exploitation in the next 30 days. Fixed in django 1.7.6, 1.8b2.
Cross-site scripting (XSS) vulnerability in the contents function in admin/helpers.py in Django before 1.7.6 and 1.8 before 1.8b2 allows remote attackers to inject arbitrary web script or HTML via a model attribute in ModelAdmin.readonly_fields, as demonstrated by a @property.
- EPSS
- 2.1% chance of exploitation in the next 30 days; higher than 81% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- djangoproject:django
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-6565-fg86-6jcx | PyPI | django | <1.7.6 | 1.7.6 |
| GHSA-6565-fg86-6jcx | PyPI | django | >=1.8a1 <1.8b2 | 1.8b2 |
| PYSEC-2015-8 | PyPI | django | <1.7.6 >=1.8a1 <1.8b2 | 1.7.6, 1.8b2 |