cve.bz

CVE-2015-0226

7.5 highEPSS 5.5%

High (7.5) in apache wss4j. EPSS 5.5% chance of exploitation in the next 30 days. Fixed in org.apache.ws.security:wss4j 1.6.17.

Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or message data, which makes it easier for remote attackers to recover the plaintext form of a symmetric key via a series of crafted messages. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-2487.

Severity

CVSS 3.0

7.5 high
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
5.5% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWE
CWE-327
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vjwc-5hfh-2vv5Mavenorg.apache.ws.security:wss4j<1.6.171.6.17
GHSA-vjwc-5hfh-2vv5Mavenorg.apache.wss4j:wss4j-ws-security-dom>=2.0.0 <2.0.22.0.2

References

Check your stackJSON