cve.bz

CVE-2014-4966

9.8 criticalEPSS 3.5%

Critical (9.8) in redhat ansible. EPSS 3.5% chance of exploitation in the next 30 days. Fixed in ansible 1.6.7.

Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.5% chance of exploitation in the next 30 days; higher than 89% of CVEs (scores of 2026-10-31)
CWE
CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wqq5-c89p-3wc3PyPIansible<1.6.71.6.7
PYSEC-2020-204PyPIansible<1.6.71.6.7

References

Check your stackJSON